Clear all

[Solved] Wittypi 3 to Wittypi 4

2 Posts
2 Users
Posts: 1
New Member
Topic starter


I have an issue with a project, I used to do it with a WittyPi 3 but I have now a Wittypi 4.

I followed the installation guide for the new software on my old SD card.

Now it doesn't work anymore, when I switched on my RaspberryPi (4 Model B) it shutdown few seconds after. I tried with and without the WittyPi on it.

I have the same issue when I start everything from scratch on a new card and I suspect it comes from the watchdog installation I have.

This is what I do for watchdog installation:

sudo apt-get install watchdog -y

sudo sed -i -e '$a\dtparam=watchdog=on' /boot/config.txt

sudo sed -i -e '$a\# Custom parameters' /etc/watchdog.conf
sudo sed -i -e '$a\watchdog-device = /dev/watchdog' /etc/watchdog.conf
sudo sed -i -e '$a\watchdog-timeout = 15' /etc/watchdog.conf
sudo sed -i -e '$a\max-load-1 = 24' /etc/watchdog.conf
sudo sed -i -e '$a\temperature-sensor = /sys/class/thermal/thermal_zone0/temp' /etc/watchdog.conf
sudo sed -i -e '$a\max-temperature = 80' /etc/watchdog.conf
sudo systemctl enable watchdog

sudo reboot

I don't really understand why it works with WittyPi 3 and not with the 4 one.

If you have any idea or suggestion on what to do to fix it that would be great.

Thanks a lot!

Posted : 15/11/2023 2:58 pm
Posts: 145
Member Admin

If your Raspberry Pi 4 keeps shutting down itself even without Witty Pi mounted on it, then the problem must come from GPIO-4 (BCM naming).

Witty Pi's software will monitor the state of GPIO-4, and the script will be blocked at this line until the GPIO-4 pin is pulled down. Once it is unblocked it will initiate a shutdown.

I think your troubleshooting may start from checking the status of GPIO-4 during the boot.

Posted : 15/11/2023 4:50 pm