Clear all

[Solved] PiGear Nano: Unable to get pictures from the HQ Camera Module

3 Posts
2 Users
Posts: 2
New Member
Topic starter

Hi there,

I followed the user manual ( to setup my PiGear Nano.
I've installed the normal Raspberry PI OS (64-bit)

After the installation, I was setting up the CSI Camera Connector:
 > sudo cp pgnano/bin/dt-blob.bin /boot/dt-blob.bin
 > sudo chown root:root /boot/dt-blob.bin
 > sudo chmod 755 /boot/dt-blob.bin

After the reboot, I wanted to check the camera:
 > libcamera-hello --list-cameras

It was showing me the camera, so the camera is detected.
By running the

 > libcamera-hello

I got the following errors:

ERROR RPI pipeline_base.cpp:1333 Camera frontend has timed out!
ERROR RPI pipeline_base.cpp:1334 Please check that your camera sensor connector is attached securely.
ERROR RPI pipeline_base.cpp:1335 Alternatively, try another cable and/or sensor.

I was using the camera on another raspberry pi and it worked, so the camera must be fine.
I've also used another cable for this one, so I guess the cables are also fine. The camera is also detected, so the cables should be fine.

My model:
 > cat /sys/firmware/devicetree/base/model

Returns: Raspberry Pi Compute Module 4 Rev 1.0

Have you got any ideas how to solve the problems?

Best regards

Posted : 29/08/2023 4:13 pm
Posts: 75
Member Admin

Have not seen these errors before, but searching those error messages leads me to this page:

Someone wrote that he fixed it by running "apt install libcamera-apps", which looks promising.



Posted : 29/08/2023 6:23 pm
Posts: 2
New Member
Topic starter


I have got the newest version of libcamera-apps.

I've tried uninstalling and installing it again but it didn't help.

In the raspi-config I should see the Camera in the Interface Options, but there is nothing.
The camera is shown with the command "libcamera-hello --list-cameras".

The issue on github didn't help me. Have you got any other ideas?

Posted : 30/08/2023 2:05 pm