Clear all

[Solved] Witty Pi 4: Tapping the On/Off switch doesn't turn on the Raspberry Pi

3 Posts
2 Users
Posts: 3
Active Member
Topic starter


I have a problem with the Witty-Pi-4 Mini.
I mounted it on my rasperry pi 4 and plugged in the power supply via usbc-cable.
If I press the On/off switch, the diode D1 just flashes for a very short time, but the rasperry pi doesn't start.
The diode d3 is frequenty flashing.

Could you help me?
Best regards

Posted : 26/05/2023 12:06 pm
Posts: 15
Member Admin

It seems the MCU (ATtiny841) on Witty Pi 4 Mini got reset when you tap the button. We have observed similar issue when the power supply was not stable enough, or there were electromagnetic interference sources nearby. As far as we know, this issue has chance to happen on Raspberry Pi B models, and we have not seen it happen on Raspberry Pi Zero models.

Do you have a capacitor (10uF or higher)? If you do, you may connect the capacitor between 3V3 and GND (as shown in the picture attached), and usually it will stabilise the 3.3 voltage and avoid this kind of issue.



Posted : 26/05/2023 12:12 pm
cknivu reacted
Posts: 3
Active Member
Topic starter

Thanks you very much 🙂

I connected the 10uF capacity and it works now.


Posted : 26/05/2023 12:57 pm