Cool stuff for Raspberry Pi, Arduino and all electronics hobby projects
Notifications
Clear all

[Solved / Archived] WittyPi4 with another HAT

13 Posts
3 Users
0 Likes
418 Views
(@schlumpf)
Posts: 10
Active Member
Topic starter
 

Hi,

i´m using the wittypi4 on my raspberry pi 4, but also i have another SIM-HAT on it, like this one

https://www.waveshare.com/wiki/SIM7600E-H_4G_HAT#Overview

Together in use the wittypi doenst work right, like the start and shutdown button doesnt work.

Does anyone have an idea what the problem could be and i how i can solve it?

Thank you.

 
Posted : 02/06/2023 1:29 pm
(@admin)
Posts: 362
Member Admin
 

If the button on Witty Pi 4 doesn't work, check if GPIO-4 is also used by your another HAT. 

If you can not let the another HAT to use a different GPIO pin, you may change the pin used by Witty Pi 4. However you will have to cut the thin copper trace (between SWITCH and GPIO-4 labels) on the back of the board, and you will need to re-wire the SWITCH pad to a new GPIO pin. Also you will need to change the software (in utilities.sh file, modify the value of HALT_PIN).

 

 
Posted : 02/06/2023 1:36 pm
(@schlumpf)
Posts: 10
Active Member
Topic starter
 

okay, i dont the switch is not nessesary as long i can the other functions of the wittypi, but i cant reach the webinterface under the port 8000.

i can get to the menue with ./wittyPi.sh, but the interface doesnt work

i will try if i can load a custom schedule, see if it works

 
Posted : 02/06/2023 2:25 pm
(@schlumpf)
Posts: 10
Active Member
Topic starter
 

the scheduler is also not working so its not only the button

without the other HAT everything works fine, sheduler also

 
Posted : 02/06/2023 2:39 pm
(@schlumpf)
Posts: 10
Active Member
Topic starter
 

actually even without the other HAT i had issues with the wittypi, after it worked for 20 minutes, i made a five minute on, five minute off schedule, and after 20 minutes nothing happened.

even the button didnt work.

i have raspberry pi os 64 bit runnin

and the pi is connected to internet with ethernet, but only now for testing. later not

What could be the issue?

thanks

 
Posted : 02/06/2023 3:05 pm
(@schlumpf)
Posts: 10
Active Member
Topic starter
 

@admin can i use the switch pin on the outside oafter i cut the connection between the switch and gpio4? , i added a screen

and which alternative pin do you recommend?

1685725863-2023-06-02_19-09.jpg
 
Posted : 02/06/2023 7:11 pm
(@admin)
Posts: 362
Member Admin
 

It is better to solve one problem a time.

If UWI is not accessible, usually you can run "diagnose.sh" script to fix the issue.

If something works without another HAT, then most probably it is due to GPIO conflicting between Witty Pi and that HAT.

If schedule script doesn't work even without another HAT, please provide more information ("nothing happen" doesn't help diagnosing the issue). The wittyPi.log file may be helpful, a picture of vidioe of your configuration may also help. 

And yes, you may use that SWITCH pin after cutting the copper trace between SWITCH and GPIO-4. You may choose another pin that is not used by anyone.

 

 
Posted : 03/06/2023 10:14 am
(@schlumpf)
Posts: 10
Active Member
Topic starter
 

okay, thank you

i´ve run diagnose.sh, i had to choose on which ip adress the interface should be createt, cause i got two, but now it works fine

so the UWI works now

 

the problem with the other HAT:

if i newly supply the RPi with power over the witty pi, together with the other HAT, it´s fine at first

i press the button to start and the RPi starts, like it should

then i press the button to shutdown, that also works, but the RPi still has it´s red light on after the system shut down and i cant start it again with the witty pi

the lamp on the witty pi isnt blinking also, so i think its not shutting down completly, it seems like the RPi is still in standby or sth. like that

 

im not sure if the gpio for is the problem, or what do you think?

thanks for your help

 
Posted : 03/06/2023 1:47 pm
(@schlumpf)
Posts: 10
Active Member
Topic starter
 

i also found this configuration in the init file of the other HAT, maybe that´s helpful

file:

 

echo "4" > /sys/class/gpio/export
sleep 0.1
echo "out" > /sys/class/gpio/gpio4/direction
echo "0" > /sys/class/gpio/gpio4/value
echo "6" > /sys/class/gpio/export
sleep 0.1
echo "out" > /sys/class/gpio/gpio6/direction
echo "0" > /sys/class/gpio/gpio6/value

 
Posted : 03/06/2023 2:12 pm
(@schlumpf)
Posts: 10
Active Member
Topic starter
 

i changed the gpio 4 that the other HAT uses to 19 and it still worked, i tried several other pins before which failed

but still i cant use it together with witty pi, it still is not booting down completly

i guess somehow the other HAT prevents the wittypi to shutdown sucessfully

 
Posted : 03/06/2023 9:53 pm
(@schlumpf)
Posts: 10
Active Member
Topic starter
 

it seems like it has to do with the power supply of the other HAT, but i found a way to manage that issue and use both together

when the HAT is once turned on and powered, it prevents the pi to be completly shutdown by wittypi

i attached the activation of the other HAT to another gpio i can control and now i can use both

 

thanks for your help

 
Posted : 04/06/2023 12:14 am
(@admin)
Posts: 362
Member Admin
 

If Raspberry Pi has been shut down but Witty Pi's red light stays on, that means Witty Pi doesn't cut the power because it doesn't know Raspberry Pi has been shut down. In such case tapping the button will not boot the Pi again.

Witty Pi monitor the voltage level on TXD pin, to know if Raspberry Pi has been shutdown. The TXD pin should go low after Rasbperry Pi has been shut down. If for any reason the TXD doesn't go low after the shutdown, then Witty Pi doesn't know about the shutdown and will not cut the power.

 
Posted : 05/06/2023 12:50 pm
(@spknmmike)
Posts: 0
New Member
 

"B" version of that hat works with WittyPi - no issues out of the box.

It's probably the conflicting with GPIO pin 4 used by most Waveshare boards for power control. Could also check your jumper setting for the "Flight Mode" on the hat and make sure it's disabled.

 
Posted : 07/06/2023 7:46 pm
Join Waitlist We will inform you when the product arrives in stock. Please leave your valid email address below.