Clear all

[Solved] Witty Pi 3 Rev 2 + RPi 3 b+ | Schedule Startup problem

4 Posts
2 Users
Posts: 2
New Member
Topic starter


I decided to write this topic as I didn’t manage after hours of work to fix my problem.

I want my Raspberry Pi to start every 15 minutes and I decide when to shutdown it.

I tried the « Schedule next shutdown » function, and it works very well.

The problem is that anytime I shutdown the Raspberry pi, it will instantly initiate startup.

Even if I schedule the next startup in 15 min, it will turn back on systematically.

I also tried to set some Schedules that were installed by default, without success…

I tried everything, disabled Low voltage, recovery voltage… I don’t know how to fix it

Posted : 24/08/2023 5:18 pm
Posts: 75
Member Admin

Different than Witty Pi 4, Witty Pi 3's alarms are provided by RTC hardware and the two alarms (for scheduling shutdown and startup) are sharing the same physical pin in the RTC chip (DS3231SN). With that said, no matter which alarm is triggered, that pin will be pulled low and Witty Pi will consider it as the same as tapping the button on Witty Pi. So a shutdown alarm may also wake up your Pi.

Your best bet is to use schedule script, and put "WAIT" in the ON state. This way the shutdown will not be scheduled. Your schedule script would look like this:

BEGIN   2023-07-01 00:00:00
END     2025-07-31 23:59:59
ON      M10      WAIT 
OFF     M5

Because of the "WAIT" keyword, your Pi would not shutdown at 10 minutes since startup, but you need to make sure the shutdown will happen before 15 minutes mark.

You may take a look a this example, which uses WAIT in schedule script:

Posted : 24/08/2023 6:55 pm
Posts: 2
New Member
Topic starter

Thank you for your quick reponse!

We misunderstood, I only created one single alarm (startup) that is supposed to wake up the pi in 15 min. I don't use Schedules, only the set_startup_time() function in order to wake it up.

The issue is that when I manually turn off my Pi (shutdown button, commands...) it will turn back on just after finishing shutdown.

My Pi just can't stay OFF for some time.

I took a multimeter and checked the PIN voltage, just after shutown, it goes from 0 to 3V even if I disabled all the alarms and schedules.

For a reason that I ignore, Witty Pi wakes up my Pi even if I didn't order anything.

Posted : 24/08/2023 7:30 pm
Posts: 75
Member Admin

Please make sure the power supply only connects to Witty Pi, and not directly connects to Raspberry Pi.

Please also confirm the power to Raspberry Pi has been cut after you shutdown your Pi. The red light on Raspberry Pi should go off.

Posting the content of wittyPi.log file may help providing more information for troubleshooting, a photo or video for your device may also help.

Posted : 25/08/2023 12:07 pm