Clear all

[Solved] Witty Pi 4 L3V7: on/off problem

4 Posts
3 Users
Posts: 4
Active Member
Topic starter

I recently purchased two of the Witty Pi 4 L3V7 boards to use on a pair Raspberry Pi Zero W's (v. 1.1)  that I had.  I did a fresh install of Bullseye Lite (32 bit), and installed the software per the instructions.  Once completed, I shutdown the Pi, plugged in the board (I am using a stacking header) and plugged in the USB-C.  The Witty board's blue led and green led turn on, and are solid, but the red and white LED's do not turn on.  The switch on the Witty is not turning on the Pi.  Occasionally the white led will 'blip'.  I tried staring at it to see if there was a specific interval to it, not after a few minutes of watching I gave up.  

If I unplug the USB-C and power the Pi directly, the red led on the Witty illuminates, and the Pi boots up, all other LED on the Witty board are off.  If I then run the script, it provides me with the temperature readings and lots of "Error: Read failed" messages and an invalid date "date: invalid date ‘0-7-21 0:3:’" (It is currently 9:23PM on 2023-07-21).  Interestingly, the power switch on the Witty does power off/on the pi even though the pi is powered, not the Witty, though the red led stays on.

Still powering the Pi directly, but the Witty board installed, I decided to re-install the software (which went well without errors) and rebooted.  Which gave the same results.  I shutdown again, and this time connected it back up to the USB-C power to the Witty board.  This time, the green LED is on solid, the blue LED is rapidly blinking (I have no battery attached to the unit), and the red LED is also on solid, the white LED is not on, or blinking.  The pi powered up on plugging in the USB-C.  

Running the at this point, displays the values and menu options without any issue. If I press the power button, the white LED turns on while I am pressing the switch, then turns off.  The Pi does power down, then immediately turns back on.  If I 'sudo shutdown -h now' it also shuts down then powers back on.  

I am confident that I am doing something wrong, but am at a loss for what it is.  I have another Witty board, but am hesitant to try it in case I have done something wrong with the first one.  Any direction that you could point me in would be greatly appreciated to resolve this.  Much thanks. 

Posted : 22/07/2023 4:00 am
Topic Tags
Posts: 145
Member Admin

If you do not connect 3.7V Lithium battery to Witty Pi 4 L3V7 board, the blue LED will quickly blink and the green LED will stay on, this is the normal behavior.

Even without the battery connected, tapping the button on board should start your Raspberry Pi, you should see the white and red LEDs turns on.

If you power your Raspberry Pi directly, Witty Pi 4 L3V7 board is not powered and its MCU is not working (so it would not react to any I2C request). The red LED on it lights up because it is directly drove by the +5V on GPIO header.

To quickly check if your Witty Pi 4 L3V7's firmware is working normally, just connect 5V to the USB-C connector and do not connect Raspberry Pi to Witty Pi 4 L3V7. The blue LED quickly blinks and green LED stays on, the red LED is off and the white LED will blink for every few seconds. If you tap the button, white and red LED turn on and white LED goes off after a few seconds.

In order to let Witty Pi work, you should only connect power supply to Witty Pi board, connecting power supply to Raspberry Pi directly should only be used for diagnosing and it should not be used in normal use cases.

If you need further help, please record a video of how the board behave and that will provide a lot of information to us.





Posted : 24/07/2023 6:39 pm
Posts: 4
Active Member
Topic starter

Thank you for the information about testing the board without plugging it into the Pi.  That was helpful.  I ended up having a bad Zero.  After testing the board as you described, and it working properly, I tried it on a different Zero I had and it worked as expected.  Thank you for your assistance. 

Posted : 26/07/2023 12:11 am
Posts: 3
New Member Customer

In my case (zero, bought l3v7 just a few weeks ago) the system works when power is totally disconnected. It also starts up automatically when 5v is connected but I cannot get it to start from my 10000mAh battery. It can charge the battery fine, it can run from the battery (when i detach the USB-c) , but it does not startup. Not with the button, not with the timer (which works with usb-c power).

Posted : 17/11/2023 4:20 pm